Classification and Marking 289
IP precedence or DSCP value for incoming frames. Again, similar to the behavior demon-
strated in Hybrid mode with the ACE dscp keyword, set ip precedence and set ip dscp,
when specified, do not supersede the configured port trust state. The PFC maintains the
ingress CoS, IP precedence, or DSCP value, as long as the corresponding mls qos trust
keyword is configured at the interface.
The following example demonstrates how to classify and subsequently mark traffic using
Native mode. The same criteria used in the Hybrid examples is used here. Again, the intent
is to mark all traffic destined for TCP ports 1720, 1731, and 1503 with a DSCP value of 26,
whereas all other traffic is marked with the default CoS setting for the interface. The first
step in the QoS policy creation is creating an ACL for all relevant traffic. When configured,
the ACL is then mapped to an administratively defined class map. You can verify these
configuration steps with the show access-list and show class-map commands.
When the desired traffic has been identified, and referenced in a class map, that class map
is then mapped to a defined policy map. In this instance, the policy map name corresponds
to a broader topic, which encompasses the traffic identified in the class map. This was
done to demonstrate the modular aspect of the relationship between class maps and policy
maps. The policy map name chosen is VideoConf. Because there are potentially different
identifiable traffic streams, you can reference multiple class maps within one policy map.
Each class map, in turn, may have its own marking parameter. For this example, the actual
audio and video streams can be identified and placed within their own class map and
marked appropriately. Therefore, the recommendation is to name the policy map
something related to the class map, but in a broader sense. Depending on how the policies
are formulated, for instance, the policy map may be named after a department or after an
application (such as VideoConf). In this scenario, the goal is to mark all traffic destined
for TCP ports 1720, 1731, and 1503 with DSCP 26. Therefore, the set ip dscp {dscp
value} command is utilized within the policy map class, along with the desired value.
native(config)# policy-map VideoConf
native(config-pmap)# class Control-traffic
native(config-pmap-c)# set ip dscp 26
native# show policy-map VideoConf
Example 8-22 Configuring and Applying a QoS Policy in Native Mode
native(config)# access-list 110 remark Control traffic for Video Conferencing App
native(config)# access-list 110 permit tcp any any eq 1720
native(config)# access-list 110 permit tcp any any eq 1731
native(config)# access-list 110 permit tcp any any eq 1503
native(config)# class-map match-any Control-traffic
native(config-cmap)# match access-group 110
native# show access-list 110
Extended IP access list 110
permit tcp any any eq 1720
permit tcp any any eq 1731
permit tcp any any eq 1503
native# show class-map Control-traffic
Class Map match-any Control-traffic (id 12)
Match access-group 110
continues
..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset