150 Chapter 6: QoS Features Available on the Catalyst 2950 and 3550 Family of Switches
Queuing of ingress packets. Not supporting input scheduling on any switch is not an issue
when maintaining the supported packet-forwarding rate of the switch. Consult the Cisco
product documentation for more information regarding the packet-forwarding rate of the
Catalyst 2950 Family and Catalyst 3550 Family of switches.
Classification and Marking
Classification establishes an internal DSCP value, which the switches use to differentiate
packets during packet processing, policing, and output scheduling and queuing. The
Catalyst 2950 Family of switches supports the following classification options:
Ingress port CoS configuration
Trust CoS
Trust DSCP
Extended trust on voice and VLANs
ACL-based classification
Classified model based on internal DSCP
CoS and DSCP mapping tables
The Catalyst 3550 Family of switches supports the following classification options:
Ingress port CoS configuration
Trust CoS
Trust DSCP
Trust IP precedence
Extended trust on voice and VLANs
Trust Cisco IP Phone
ACL-based classification
Classification model based on internal DSCP
CoS and DSCP mapping tables
Both the trust CoS and trust DSCP options allow for DSCP and CoS passthrough, respec-
tively. In addition, the trust DSCP option on the Catalyst 3550 Family of switches supports
DSCP mutation.
Internal DSCP and Mapping Tables
As mentioned in the architecture overview section, the Catalyst 2950 Family and 3550
Family of switches utilize an internal DSCP value to represent classification and marking
of frames as the frames traverse the switch. Because the switches use internal DSCP values,
Classification and Marking 151
the switch maps ingress DSCP, CoS, and IP precedence to the internal DSCP values when
dictated by the classification configuration. When trusting DSCP, the switch maps ingress
packets’ DSCP directly to an internal DSCP value. The only exception is in configuring
DSCP mutation. Figure 6-5 illustrates the logical depiction of internal DSCP as a packet
traverses a Catalyst 2950 or 3550 switch.
Figure 6-5 Logical Depiction of Internal DSCP
For CoS and IP precedence mapping to an internal DSCP, the switches use a CoS-to-DSCP
and an IP precedence-to-DSCP mapping table, respectively. Tables 6-2 and 6-3 indicate the
default mappings for the CoS-to-DSCP and IP precedence-to-DSCP mappings, respectively.
The IP precedence-to-DSCP mapping table is configurable on the Catalyst 3550 Family of
switches, whereas both the Catalyst 2950 Family and the Catalyst 3550 Family of switches
support custom configuration of the CoS-to-DSCP mapping tables. To configure the CoS-
to-DSCP and IP precedence-to-DSCP mapping tables, use the following commands,
respectively:
mls qos map cos-dscp
DSCP-list
mls qos map IP-prec-dscp
DSCP-list
DSCP-list represents the eight DSCP mapping values for each IP precedence value 0 to 7.
For example, a DSCP-list of 0 10 16 25 36 46 48 50 for a CoS-DSCP mapping configu-
ration results in the CoS value of 0 mapping to a DSCP value 0, CoS value of 1 mapping to
a DSCP value of 10, and so forth. Examples 6-2 and 6-3 illustrate a user configuring and
Table 6-2 Default CoS-to-DSCP Mapping Table
CoS 01234567
DSCP 0 8 162432404856
Table 6-3 Default IP Precedence-to-DSCP Mapping Table
IP Precedence 01234567
DSCP 0 8 162432404856
QoS Packet Processing
Determine
Transmit Queue
MarkPolicing
Policing may
markdown internal
DSCP.
Egress
Packet
Classification
Ingress
Packet
The Shaping and Sharing
configurations determine queue
scheduling.
Transmit Queue
Queue 4
Queue 3
Queue 2
Queue 1
Internal DSCP is
derived from Ingress
Packet DSCP, CoS, IP
Precedence, port
configuration, or ACL
configuration and
DSCP mapping tables.
Packet with
Internal DSCP
Internal DSCP
determines egress
CoS and DSCP values.
The egress CoS
determines Queue
placement.
152 Chapter 6: QoS Features Available on the Catalyst 2950 and 3550 Family of Switches
verifying configuration of a CoS-to-DSCP mapping table and a IP precedence-to-DSCP
mapping table, respectively.
Ingress Port CoS Configuration
The Catalyst 2950 Family and 3550 Family of switches allow for static configuration of
ingress CoS values used for DSCP mapping. The switches use ingress port CoS configura-
tions to classify untagged frames and override CoS values on tagged frames.
To configure a switch interface to represent a CoS value for an untagged frame, use the
following interface commands:
mm
mm
ll
ll
ss
ss
qq
qq
oo
oo
ss
ss
tt
tt
rr
rr
uu
uu
ss
ss
tt
tt
cc
cc
oo
oo
ss
ss
mls qos cos
cos_value
cos_value represents the CoS value to assign to untagged frames. The switch requires both
configuration commands for assigning CoS values to untagged frames.
Example 6-4 illustrates an example of an interface configured for trusting CoS for tagged
frames and the default configuration of assigning a CoS value of 0 to untagged frames.
Example 6-2 User Configuring and Verifying CoS-to-DSCP Mapping Table
Switch#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#mls qos map cos-dscp 0 8 16 30 30 46 50 50
Switch(config)#end
Switch#show mls qos map cos-dscp
Cos-dscp map:
cos: 0 1 2 3 4 5 6 7
--------------------------------
dscp: 0 8 16 30 30 46 50 50
Example 6-3 User Configuring and Verifying IP Precedence-to-DSCP Mapping Table
3550#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
3550(config)#mls qos map ip-prec-dscp 0 8 16 28 30 46 50 55
3550(config)#end
3550#show mls qos map ip-prec-dscp
IpPrecedence-dscp map:
ipprec: 0 1 2 3 4 5 6 7
--------------------------------
dscp: 0 8 16 28 30 46 50 55
Example 6-4 Example Interface Configuration of Trusting CoS Values of Tagged Frames and Assigning Default
CoS Value 0 to Untagged Frames
Switch# show running-config
Building configuration…
!
(text deleted)
interface FastEthernet0/1
Classification and Marking 153
Example 6-5 illustrates an interface configured for trusting CoS for tagged frames and
assigning a CoS value of 5 to untagged frames.
To configure an overriding CoS value on untagged and tagged frames on a switch interface,
use the following commands:
mm
mm
ll
ll
ss
ss
qq
qq
oo
oo
ss
ss
tt
tt
rr
rr
uu
uu
ss
ss
tt
tt
cc
cc
oo
oo
ss
ss
mls qos cos
cos_value
mm
mm
ll
ll
ss
ss
qq
qq
oo
oo
ss
ss
cc
cc
oo
oo
ss
ss
override
The mls qos cos override signifies to override tags frames with the CoS value specified in
the mls qos cos cos_value command. Example 6-6 shows an interface configuration using
the override feature.
switchport access vlan 53
switchport voice vlan 701
no ip address
mls qos trust cos
spanning-tree portfast
(text deleted)
end
Example 6-5 Sample Interface Configuration of Trusting CoS Values of Tagged Frames and Assigning a Port CoS
Value 5 to Untagged Frames
Switch# show running-config
Building configuration…
!
(text deleted)
interface FastEthernet0/1
switchport access vlan 53
switchport voice vlan 700
no ip address
mls qos cos 5
mls qos trust cos
spanning-tree portfast
(text deleted)
end
Example 6-6 Sample Interface Configuration of Trusting and Assigning a Port CoS Value 5 to Untagged and
Tagged Frames
Switch# show running-config
Building configuration…
!
(text deleted)
interface FastEthernet0/1
switchport access vlan 53
switchport voice vlan 700
no ip address
Example 6-4 Example Interface Configuration of Trusting CoS Values of Tagged Frames and Assigning Default
CoS Value 0 to Untagged Frames (Continued)
continues
154 Chapter 6: QoS Features Available on the Catalyst 2950 and 3550 Family of Switches
Assigning a port CoS value to an ingress frame does not necessarily result in the switch
transmitting the frame with that CoS value. The port CoS value only determines the internal
DSCP value of the ingress frame, and the switch may mark the frame, mark down the frame
during policing, or use a nondefault DSCP-to-CoS mapping table before egress trans-
mission of the frame.
To verify any classification configuration of an interface, use the following command:
show mls qos interface
[interface-name]
Example 6-7 illustrates sample output from this command on a Catalyst 3550 switch.
Trust DSCP
The trust DSCP configuration maps an ingress packet’s DSCP value directly to the internal
DSCP value. Trust DSCP is the recommended trust configuration for directly attached
switches that perform classification and marking on ingress. Because classification and
marking occurs on ingress for interconnected switch ports, just trusting DSCP allows the
current switch to maintain the original ingress classification and marking of the connected
switch. Trusting DSCP is also a choice configuration for interfaces connected to Cisco IP
Phones. Cisco IP Phones mark frames with DSCP and CoS values, and just trusting DSCP
on frames from the Cisco IP Phone is a common practice.
Figure 6-6 illustrates an example of this behavior. Switch-2 trusts DSCP on the attached
Cisco IP Phone. Switch-1 preserves the classification of Switch-2 by just trusting DSCP on
the interface connecting the two switches. As a result, Switch-1 preserves the classification
done by Switch-2.
mls qos cos 5
mls qos trust cos
mls qos cos override
spanning-tree portfast
(text deleted)
end
Example 6-7 Sample Output from the show mls qos interface Command
Switch#show mls qos interface GigabitEthernet 0/1
GigabitEthernet0/1
trust state: trust dscp
trust mode: trust dscp
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
trust device: none
Example 6-6 Sample Interface Configuration of Trusting and Assigning a Port CoS Value 5 to Untagged and
Tagged Frames (Continued)
..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset