180 Chapter 6: QoS Features Available on the Catalyst 2950 and 3550 Family of Switches
To demonstrate and measure the scheduling behavior of strict-priority queuing and WRR
on transmit queues, three packet-generator ports were connected to the switch as shown in
Figure 6-11 using the switch configuration shown in Example 6-28. The first traffic-
generator port connected to interface GigabitEthernet0/1 was sending 1 Gbps of traffic with
a CoS value of 0, whereas the traffic-generator port connected to interface
GigabitEthernet0/2 was sending 100 Mbps of traffic with a CoS value of 5. A third traffic
generator connects to interface FastEthernet0/1 to measure the received rate of each packet
type. Table 6-7 shows the result of a strict-priority queue versus several configurations
using WRR with default CoS-to-transmit queue mappings.
Figure 6-11 Network Topology for Demonstrating Strict-Priority Queuing Versus WRR
Example 6-28 Interface Configuration for Demonstrating Strict-Priority Queuing
Switch#show running-config
Building configuration...
(text deleted)
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
mls qos trust cos
spanning-tree portfast
!
(text deleted)
!
interface GigabitEthernet0/1
switchport access vlan 2
switchport mode access
mls qos trust cos
spanning-tree portfast
!
!
interface GigabitEthernet0/2
switchport access vlan 2
switchport mode access
mls qos trust cos
spanning-tree portfast
!
end
Packet
Generator
Gig 0/1
Catalyst 2950
Gig 0/2
Fas 0/1
Congestion Management and Avoidance 181
Congestion Avoidance with the 3550 Family of Switches
The Catalyst 3550 Family of switches supports the following congestion avoidance mecha-
nisms on Gigabit Ethernet-capable interfaces:
Tail-drop thresholds
WRED drop thresholds
Transmit queue size manipulation
Furthermore, the Catalyst 3550 Family of switches supports only configuration of
minimum reserve levels for congestion avoidance on Fast Ethernet interfaces.
Tail Drop
The Catalyst 3550 Family of switches utilizes two thresholds for congestion avoidance. By
default, the switch maps all packets to a single threshold per queue. As a result, when a
transmit queue becomes full, the switch drops any further packets needing placement into
the respective transmit queue. This behavior is the default when any queue becomes
congested and is subsequently unable to hold additional packets.
The Catalyst 3550 Family of switches allows for two tail-drop thresholds, whereas the
switch tail drops packets with a lower priority over packets with a higher priority. The
switch CLI refers to these thresholds as thresholds-1 and thresholds-2, respectively. The
Catalyst 3550 Family of switches employs priorities for thresholds strictly on internal
DSCP. The ingress interface determines the egress tail-drop threshold mapping and this
configuration is only applicable to Gigabit Ethernet-capable interfaces. As a result, the
switch treats all ingress packets from Fast Ethernet interfaces with the threshold-2 configuration.
In practice, tail-drop thresholds are useful in mitigating congestion. Consider, for example,
a large network consisting of high-priority data and voice applications. The high-priority
data application is built on TCP/IP and provides for file sharing between network users. The
application adapts well to TCP/IP back-pressure and packet loss. The network uses voice
applications for IP telephony. Because both applications are critical, the network adminis-
trators assign a DSCP value of 40 to the file-sharing application while using the default
Table 6-7 Demonstrating Strict-Priority Queuing Versus WRR on Transmit Queues on the Catalyst 2950
Trial Description
No. of Packets with
CoS = 0 Received
No. of Packets with
CoS = 5 Received
Default configuration (strict-priority queuing) 0 148,805
WRR queue bandwidth 25 25 25 25 74,400 74,400
WRR queue bandwidth 10 20 30 40 35,705 113,100
WRR queue bandwidth 10 20 100 100 13,000 135,805
182 Chapter 6: QoS Features Available on the Catalyst 2950 and 3550 Family of Switches
DSCP value associated with Cisco IP Phones, 46. Packets from both applications occupy
transmit queue 3. The switch is using WRR to service queue 3 with half the available
bandwidth on egress interfaces. Before implementing tail-drop thresholds, the network
administrators noticed that the file-sharing application was filing the transmit queue 3
causing excessive drops for voice applications. To remedy this situation, the network
administrators implemented tail-drop thresholds. The network administrators configured
the switch to tail drop packets from the file-sharing application when the queue becomes
30 percent full while only dropping voice application traffic when the queue is 100 percent
full. This configuration yields ample transmit queue space for the voice applications, while
the file-sharing program maintained high-priority service in transmit queue 3 but was
unable to monopolize the buffer space.
To configure an interface for tail-drop congestion avoidance, use the following interface
command.
wrr-queue threshold
queue-id threshold-percentage1 threshold-percentage2
queue-id refers to the respective transmit queue, 1 through 4. threshold-percentage1 and
threshold-percentage2 refer to the tail-drop percentage thresholds respectively. Valid
percentages are in the range 1 to 100.
To configure the ingress interface for threshold mapping, use the following interface config-
uration command:
wrr-queue dscp-map
threshold-id dscp1 ... dscp8
threshold-id represents a number 1 or 2 for threshold-precentage1 or 2, respectively.
dscp1 … dscp8 represents up to eight DSCP values for threshold mapping.
NOTE As mentioned previously, the DSCP-to-threshold mapping resides on the ingress interface
of traffic. As a result, for packets to adhere to specific thresholds on the egress interfaces,
the switch requires the mapping configuration on the ingress interfaces. In addition, only
Gigabit Ethernet-capable interfaces support DSCP-to-threshold mapping.
Example 6-29 illustrates sample interface configurations for DSCP mapping to tail-drop
thresholds. GigabitEthernet0/1 is the ingress interface, whereas GigabitEthernet0/2 is the
egress interface of the packet flow. Ingress packets with DSCP values 40 and 46 on
GigabitEthernet0/1 map to threshold 2. The threshold percentages are 50 percent and 100
percent, respectively.
Example 6-29 Sample Interface Configuration for Congestion Avoidance Using Tail-Drop Thresholds
Current configuration : 198 bytes
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
Congestion Management and Avoidance 183
WRED Drop
With the tail-drop congestion avoidance mechanism, the Catalyst 3550 Family of switches
drops packets when queues reach a certain percentage threshold or become full. The use of
tail drop may result in an undesirable behavior of applications that specifically use TCP/IP.
When a queue becomes full or reaches a certain percentage for packets matching a specific
threshold, the tail drop instantaneously drops packets until the respective queue is no longer
full. When these packet drops occur, TCP/IP applications reduce bandwidth accordingly.
When the queue is no longer full and able to accept more packets, however, TCP/IP appli-
cations begin to increase throughput, which results in another full transmit queue condition.
To utilize the transmit queue more effectively and prevent TCP/IP from increasing and
decreasing throughput at relatively the same time, the condition also known as global
synchronization of TCP, the Catalyst 3550 Family of switches supports WRED. Chapter 2,
in the “Congestion Avoidance” section, discusses global synchronization of TCP in more
detail.
The Catalyst 3550 Family of switches uses the WRED algorithm to randomly drop packets
in a transmit queue before thresholds and queue full conditions. In this manner, multiple
TCP/IP applications randomly reduce bandwidth instead of simultaneously reducing the
transmit rate. Tail-drop conditions may still occur when using the WRED algorithm under
periods of considerable congestion, low-percentage threshold values, or with applications
that do not decrease throughput accordingly. A practical example is using WRED to handle
congestion on an interface to a core switch that carries multiple file transfers and voice
application traffic. To prevent congestion of higher-priority traffic and prevent all the file
transfers from throttling bandwidth at the same time, WRED provides the best solution over
tail dropping.
Configuration and implementation of WRED mirrors tail drop. The Catalyst 3550 Family
of switches utilizes two configurable thresholds that signify percentages to randomly
discard packets. In this manner, the switch is configurable to allow for random drop of
packets with a lower priority over packets with a higher priority. The switch CLI refers to
these thresholds as thresholds-1 and thresholds-2, respectively. The Catalyst 3550 Family
switchport mode trunk
no ip address
wrr-queue dscp-map 2 40 46
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
mls qos trust dscp
wrr-queue threshold 1 50 100
!
Example 6-29 Sample Interface Configuration for Congestion Avoidance Using Tail-Drop Thresholds (Continued)
184 Chapter 6: QoS Features Available on the Catalyst 2950 and 3550 Family of Switches
of switches employs assignment to thresholds strictly based on internal DSCP. The ingress
interface determines the egress tail-drop threshold mapping and this configuration is only
applicable to Gigabit Ethernet-capable interfaces. As a result, the switch treats all ingress
packets from Fast Ethernet interfaces with the threshold-2 configuration.
To configure the egress interface for WRED, use the following command:
wrr-queue random-detect max-threshold
queue-id threshold-percentage1 threshold-
percentage2
queue-id refers to the respective transmit queue, 1 through 4. threshold-percentage1 and
threshold-percentage2 refer to the tail-drop percentage thresholds, respectively. Valid
percentages are in the range 1 to 100.
To configure the ingress interface for threshold mapping, use the following interface config-
uration command:
wrr-queue dscp-map
threshold-id dscp1 ... dscp8
threshold-id represents a number 1 or 2 for threshold-precentage1 or 2, respectively. dscp1
… dscp8 represents up to eight DSCP values for threshold mapping.
Example 6-30 shows a sample interface configuration for DSCP mapping to WRED
thresholds. GigabitEthernet0/1 is the ingress interface, whereas GigabitEthernet0/2 is the
egress interface of the packet flow. Ingress packets with DSCP values 40 and 46 on
GigabitEthernet0/1 map to threshold 2. The threshold percentages are 50 percent and 100
percent, respectively.
Use the following command to gather statistics about queue drops per threshold:
show mls qos interface [
interface_name
] statistics
Example 6-30 Sample Interface Configuration for Congestion Avoidance Using WRED Thresholds
Current configuration : 198 bytes
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
wrr-queue dscp-map 2 40 46
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
mls qos trust dscp
wrr-queue random-detect max-threshold 1 20 90
wrr-queue random-detect max-threshold 2 25 100
wrr-queue random-detect max-threshold 3 50 100
!
..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset