QoS Support on the Catalyst 2948G-L3, 4908G-L3, and Catalyst 4000 Layer 3 Services Module 243
To demonstrate WRR behavior, several trials were performed using the topology in Figure 7-8.
In each trial, a traffic generator transmitted traffic to the switch at 1 Gbps on both supervisor
ports 1/1 and 1/2. The ingress traffic on port 1/1 had an IP precedence value of 0, and ingress
traffic on port 1/2 had an IP precedence value of 7. The traffic was routed from interfaces 1/1
and 1/2 out to interface Gigabit Ethernet 1 on the WS-X4232-L3 module. The traffic
generated was also connected to this port to measure the egress traffic rate for both streams.
In the first trial, the default QoS mapping configuration was used. In the second trial, the
QoS mapping configuration was changed such that traffic from both streams mapped to the
same WRR weight. Table 7-10 summarizes the results of the trial.
Based on the WRR bandwidth formula, both trials yielded expected results. For the default
WRR mapping trial, the router used only two queues. As a result, the sum of all weighted values
was 5 (because Q1 has a weight of 1 and Q4 has a weight of 4). Therefore, the derived formula
for the effective bandwidth for the IP precedence traffic of 7 was computed as follows:
(W/S)x B = n
(4/5) x 1.0 Gbps = 800 Mbps for IP precedence 7 traffic
For the second trial, mapping all the IP precedence values to the same WRR weight yields
an even distribution of egress traffic for both streams.
Per-Port Traffic Shaping
Traffic shaping uses the leaky token bucket algorithm. The leaky token bucket algorithm
discussed earlier in this chapter for the Catalyst 4000 IOS Family also applies to the
Catalyst 2948G-L3 and 4908G-L3 Layer 3 switches and the WS-X4232-L3. Although the
hardware architecture and leaky token bucket algorithm implementations differ signifi-
cantly between the two types of switches, the algorithm still applies for understanding the
rate and burst parameters for the Catalyst 2948G-L3 and 4908G-L3 Layer 3 switches and
the WS-X4232-L3 Layer 3 services switches. Note that unlike rate-limiting policers, traffic
shaping actually buffers packets that exceed the specified rate.
Use the following command to configure traffic shaping in the interface configuration mode:
traffic-shape
rate burst
Table 7-10 WRR on the Catalyst WS-X4232-L3 Module
Trial Default WRR Mapping
All IP Precedence Map
to the Same WRR Weight
Measured rate of traffic for frames
with IP precedence (0)
200 Mbps 500 Mbps
Measured rate of traffic for frames
with IP precedence (7)
800 Mbps 500 Mbps
244 Chapter 7: QoS Features Available on the Catalyst 4000 IOS Family of Switches and the Catalyst
rate represents the traffic-shaping rate in bps. The Catalyst 2948G-L3 and 4908G-L3 Layer 3
switches and the WS-X4232-L3 module support configuration of 32 kbps to the maximum
interface speed in 1-bps increments for egress shaping. burst defines the burst size in bits.
Example 7-31 illustrates a sample configuration of traffic shaping.
Rate Limiting
Applications that are sensitive to delay and jitter, such as VoIP, interactive video, and stock
tickers, do not tolerate the buffering that occurs when traffic shaping is active. Therefore,
caution is necessary when configuring and applying traffic shaping to VoIP networks.
Rate limiting does not buffer packets. Instead, the switch drops packets over the specified
rate and above burst. The Catalyst 2948G-L3 and 4908G-L3 Layer 3 switches and the WS-
X4232-L3 switches do not support any other action for out-of-profile packets other than
drop. These switches do support configuration of ingress and egress rate limiting in both
ingress and egress applications.
Use the following interface command to configure rate limiting:
rate-limit [input | output]
rate burst
rate defines the target rate on a per-interface basis in bps. The Catalyst 2948G-L3 and
4908G-L3 Layer 3 switches and the WS-X4232-L3 support rates from 32000 bps to the
maximum link speed in 1-bps increments. burst represents the burst size in bits configured
in 1-byte increments between 0 and 64000 bytes. Example 7-32 shows a sample interface
configuration for rate limiting.
Example 7-31 Traffic Shaping Sample Configuration
Router#show running-config
Building configuration...
(text deleted):
!
interface GigabitEthernet1
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
traffic-shape rate 1540000 20000
(text deleted)
!
end
Example 7-32 Sample Configuration of Rate Limiting Applied Ingress
Router#show running-config
Building configuration...
(text deleted):
!
interface GigabitEthernet2
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
rate-limit input 5000000 64000
(text deleted)
!
end
QoS Support on the Catalyst 2948G-L3, 4908G-L3, and Catalyst 4000 Layer 3 Services Module 245
Case Study
Example 7-33 illustrates a typical configuration of a WS-X4232-L3 in slot 2 of a Catalyst
4000 chassis as illustrated in Figure 7-8.
Figure 7-8 Case Study Topology
Example 7-33 Case Study Configuration for Figure 7-8
Router#show running-config
Building configuration...
(text deleted)
!
qos mapping destination GigabitEthernet1 precedence 0 wrr-weight 1
qos mapping destination GigabitEthernet1 precedence 1 wrr-weight 1
qos mapping destination GigabitEthernet1 precedence 2 wrr-weight 4
qos mapping destination GigabitEthernet1 precedence 3 wrr-weight 2
qos mapping destination GigabitEthernet3 precedence 0 wrr-weight 1
qos mapping destination GigabitEthernet3 precedence 1 wrr-weight 1
qos mapping destination GigabitEthernet3 precedence 2 wrr-weight 4
qos mapping destination GigabitEthernet3 precedence 3 wrr-weight 2
qos mapping destination GigabitEthernet4 precedence 0 wrr-weight 1
L3
L3
L3
L3
Catalyst 6500
with MSFC II
Cisco IP
Phones
Workstations
Catalyst 6500
with MSFC II
Cisco IP
Phones
Workstations
Catalyst 4006 Catalyst 4006
g1
g2
g4
g3
WS-X4232-L3
g1
g2
g4
g3
WS-X4232-L3
continues
246 Chapter 7: QoS Features Available on the Catalyst 4000 IOS Family of Switches and the Catalyst
qos mapping destination GigabitEthernet4 precedence 1 wrr-weight 1
qos mapping destination GigabitEthernet4 precedence 2 wrr-weight 4
qos mapping destination GigabitEthernet4 precedence 3 wrr-weight 2
(text deleted)
!
interface GigabitEthernet1
ip address 10.0.1.2 255.255.255.0
no ip directed-broadcast
rate-limit output 100000 64000
!
interface GigabitEthernet2
ip address 10.0.2.2 255.255.255.0
no ip directed-broadcast
!
interface GigabitEthernet3
no ip address
no ip directed-broadcast
no negotiation auto
!
interface GigabitEthernet3.1
encapsulation dot1Q 1
ip address 10.1.1.2 255.255.255.0
no ip redirects
no ip directed-broadcast
standby 1 ip 10.1.1.1
!
interface GigabitEthernet3.3
encapsulation dot1Q 3 native
ip address 10.1.3.2 255.255.255.0
no ip redirects
no ip directed-broadcast
standby 3 ip 10.1.3.1
!
interface GigabitEthernet4
no ip address
no ip directed-broadcast
no negotiation auto
!
interface GigabitEthernet4.2
encapsulation dot1Q 2
ip address 10.1.2.2 255.255.255.0
no ip redirects
no ip directed-broadcast
standby 2 ip 10.1.2.1
!
interface GigabitEthernet4.4
encapsulation dot1Q 4
ip address 10.1.4.2 255.255.255.0
no ip redirects
no ip directed-broadcast
standby 4 ip 10.1.4.1
!
(text deleted)
!
end
Example 7-33 Case Study Configuration for Figure 7-8 (Continued)
..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset