QoS Support on the Catalyst 4000 IOS Family of Switches 235
vtp domain qos_TEST
vtp mode transparent
ip subnet-zero
!
!
class-map match-all MATCH_FILE_SHARING_FRAMES
match access-group 100
!
!
policy-map LIMIT_FILE_SHARING
class MATCH_FILE_SHARING_FRAMES
police aggregate LIMIT_32KBPS
!
!
!
vlan 501-506,700
!
interface GigabitEthernet1/1
description Uplink to Core
no switchport
ip address 10.1.1.2 255.255.255.0
qos trust dscp
tx-queue 1
bandwidth 100 mbps
tx-queue 2
bandwidth 500 mbps
tx-queue 3
bandwidth 100 mbps
priority high
tx-queue 4
bandwidth 50 mbps
!
interface GigabitEthernet1/2
description Uplink to Core
no switchport
ip address 10.1.2.2 255.255.255.0
qos trust dscp
tx-queue 1
bandwidth 50 mbps
tx-queue 2
bandwidth 500 mbps
tx-queue 3
bandwidth 100 mbps
priority high
tx-queue 4
bandwidth 100 mbps
!
interface GigabitEthernet5/1
description Link to Access Switch 501
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 501,700
qos trust dscp
Example 7-28 Case Study Configuration (Continued)
continues
236 Chapter 7: QoS Features Available on the Catalyst 4000 IOS Family of Switches and the Catalyst
tx-queue 1
bandwidth 100 mbps
tx-queue 2
bandwidth 500 mbps
tx-queue 3
bandwidth 100 mbps
priority high
tx-queue 4
bandwidth 50 mbps
!
(text deleted)
interface FastEthernet6/1
description SNA Server
switchport mode access
qos cos 2
spanning-tree portfast
!
interface FastEthernet6/2
description Edge_Router
ip address 192.168.1.2 255.255.255.0
tx-queue 1
shape 1.0 mbps
tx-queue 2
shape 1.0 mbps
tx-queue 3
shape 500 kbps
tx-queue 4
shape 500 kbps
!
(text deleted)
!
interface FastEthernet6/10
switchport mode access
switchport voice vlan 700
qos trust dscp
tx-queue 3
priority high
spanning-tree portfast
!
(text deleted)
!
interface Vlan501
description Data VLAN
ip address 10.1.51.2 255.255.255.0
no ip redirects
service-policy input LIMIT_FILE_SHARING
service-policy output LIMIT_FILE_SHARING
standby 51 ip 10.1.51.1
!
(text deleted)
!
interface Vlan700
Example 7-28 Case Study Configuration (Continued)
QoS Support on the Catalyst 4000 IOS Family of Switches 237
In Example 7-28, interfaces Gigabit Ethernet 1/1 and 1/2 connect directly to the core as
Layer 3 interfaces; therefore, trusting DSCP on ingress frames is desirable. The qos trust
dscp configuration on each interface achieves this desired configuration. Although not
illustrated in the configuration, interfaces Gigabit Ethernet 5/1 through 5/6 connect directly
to access layer Catalyst 4506 switches. In this example, the access layer switches are
responsible for determining the legitimacy of DSCP values on ingress frames. As a result,
trusting DSCP on these connections is advantageous. In addition, the Cisco IP Phones
connected to interfaces Fast Ethernet 6/10 through 6/48 require trusting of DSCP to differ-
entiate the VoIP frames.
An SNA server connected off Fast Ethernet 6/1 is sending non-IP frames. These packets
control a critical application and need classification and scheduling as appropriate. The
frames have no IP header, and the server transmits the frames with a CoS value of zero. As
a result, configuring the interface for qos cos 2 applies an internal DSCP from the CoS-to-
DSCP mapping table sufficient for prioritizing these frames. In this example, the SNA
frames map to transmit queue 2.
The application of the policy map in the configuration intends to limit the amount of file-
sharing traffic crossing VLAN boundaries. As a result, the switch applies the
LIMIT_FILE_SHARING policy map to the access VLANs, ingress and egress. The policy
map uses an aggregate policer to limit traffic to only 32 kbps for file-sharing applications
that match the class map clause defined in ACL 100.
For more accurate output scheduling, the interfaces connected to other switches use a
nondefault sharing configuration. Transmit queues 1 to 4 share traffic at rates of 50 Mbps,
500 Mbps, 100 Mbps, and 100 Mbps, respectively. NFS applications are marking their
traffic with a DSCP value of 20 by default. To provide adequate sharing of traffic up to 500
Mbps, transmit queue 2 receives 500 Mbps as a share rate. Transmit queue 3 is strictly for
VoIP traffic. The topology consists only of 100 Cisco IP Phones and restricting the transmit
queue 3 to 100 Mbps is more than adequate for the amount of voice traffic passing between
the switches. Because VoIP traffic maps to transmit queue 3 by default, configuring transmit
description Voice VLAN
ip address 10.70.1.2 255.255.255.0
no ip redirects
standby 70 ip 10.70.1.1
standby 70 preempt
!
(text deleted)
!
access-list 100 permit tcp any any eq 30000
!
(text deleted)
!
end
Switch#
Example 7-28 Case Study Configuration (Continued)
..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset