QoS Support on the Catalyst 4000 IOS Family of Switches 225
The Catalyst 4000 IOS Family of switches supports congestion management through the
use these queuing and scheduling mechanisms that occur after packet processing. Classifi-
cation distinguishes packets into multiple egress queues, whereas scheduling differentiates
service by transmitting packets out of these queues in a specific order.
Queuing and scheduling use the following QoS-specific features for building the
congestion management model:
Port Transmit Queues
Mapping Internal DSCP to Transmit Queues
Strict-Priority Queuing
Sharing
Shaping
Mapping Internal DSCP to CoS
Port Transmit Queues
The Catalyst 4000 IOS Family of switches uses a shared memory architecture. The shared
memory architecture handles all output queuing and scheduling on the supervisor engine
versus other Catalyst platforms that depend on line-module architecture for output queuing
and scheduling. As a result, all ports utilize four transmit egress queues labeled 1 to 4.
Gigabit Ethernet interfaces employ a queue size of 1920 packets, whereas Fast Ethernet and
nonblocking Gigabit Ethernet interfaces utilize a queue size of 240 packets. Table 3-9 in
Chapter 3 discusses which line-module interfaces are nonblocking. Software versions
available at the time of publication do not allow for configuration of the queue size.
Mapping Internal DSCP to Transmit Queues
After packet processing occurs, the switch places the packet into a transmit queue for
scheduling. By default, the switch places packets with higher DSCP values into higher-
numbered transmit queues. Nevertheless, the switch services all transmit queues round-
robin by default. The strict-priority queue, shaping, and sharing configurations allow for
differentiating service based on the transmit queue. Table 7-4 lists the default internal
DSCP to transmit queue mapping.
Table 7-4 Default Internal DSCP-to-Transmit Queue Mapping Table
DSCP Values Transmit Queue
0–15 0
16–31 1
32–47 2
48–63 3
226 Chapter 7: QoS Features Available on the Catalyst 4000 IOS Family of Switches and the Catalyst
Use the following command to display the internal DSCP–to–transmit queue mapping:
ss
ss
hh
hh
oo
oo
ww
ww
qq
qq
oo
oo
ss
ss
mm
mm
aa
aa
pp
pp
ss
ss
dd
dd
ss
ss
cc
cc
pp
pp
tt
tt
xx
xx
--
--
qq
qq
uu
uu
ee
ee
uu
uu
ee
ee
Use the following global configuration command to configure the internal DSCP to the
transmit queue:
[no] qos map dscp
dscp_values
to tx-queue
queue-id
dscp_values represents configuration for up to eight DSCP values to map to a transmit
queue. queue_id represents one of the four transmit queues. For configuring mapping of
more than eight DSCP values, use multiple commands.
Example 7-21 displays the default DSCP-TxQueue mapping table, configures the DSCP-
TxQueue mapping table for assigning DSCP values 40 to 49 to queue 1, and verifies the
DSCP-TxQueue mapping table configuration.
Strict-Priority Queuing
The Catalyst 4000 IOS Family of switches offers strict-priority, Low-Latency Queuing by
designating transmit queue 3 as a high-priority transmit queue. By assigning transmit queue 3
as a high-priority transmit queue, the switch transmits packets out of transmit queue 3
Example 7-21 Displaying, Configuring, and Verifying the DSCP-to-Transmit Queue Mapping Table
Switch#show qos maps dscp tx-queue
DSCP-TxQueue Mapping Table (DSCP = d1d2)
d1 : d2 0 1 2 3 4 5 6 7 8 9
-------------------------------------
0 : 01 01 01 01 01 01 01 01 01 01
1 : 01 01 01 01 01 01 02 02 02 02
2 : 02 02 02 02 02 02 02 02 02 02
3 : 02 02 03 03 03 03 03 03 03 03
4 : 03 03 03 03 03 03 03 03 04 04
5 : 04 04 04 04 04 04 04 04 04 04
6 : 04 04 04 04
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#qos map dscp 40 41 42 43 44 45 46 47 to tx-queue 1
Switch(config)#qos map dscp 48 49 to tx-queue 1
Switch(config)#end
Switch#show qos maps dscp tx-queue
DSCP-TxQueue Mapping Table (DSCP = d1d2)
d1 : d2 0 1 2 3 4 5 6 7 8 9
-------------------------------------
0 : 01 01 01 01 01 01 01 01 01 01
1 : 01 01 01 01 01 01 02 02 02 02
2 : 02 02 02 02 02 02 02 02 02 02
3 : 02 02 03 03 03 03 03 03 03 03
4 : 01 01 01 01 01 01 01 01 01 01
5 : 04 04 04 04 04 04 04 04 04 04
6 : 04 04 04 04
QoS Support on the Catalyst 4000 IOS Family of Switches 227
before any other queue until the queue reaches its share rate. The next section, “Sharing,
discusses share rate.
The recommended use of the high-priority queue is for time-sensitive packet flows, such as
VoIP flows, stock tickers, and, in some cases, video conferencing. Because of the
aggressive scheduling nature of the higher priority, strict-priority queues may starve lower-
priority queues when the high-priority queue consistently contains packets to transmit.
Use the following interface transmit queue command to configure transmit queue 3 as a
high-priority queue:
pp
pp
rr
rr
ii
ii
oo
oo
rr
rr
ii
ii
tt
tt
yy
yy
hh
hh
ii
ii
gg
gg
hh
hh
Example 7-22 shows a sample configuration of an interface configured with a strict-priority
queue.
Sharing
The Catalyst 4000 IOS Family of switches supports QoS bandwidth sharing per transmit
queue on nonblocking Gigabit Ethernet interfaces. Table 3-9 in Chapter 3 discusses which
Gigabit Ethernet line modules and ports are nonblocking.
Because different DSCP and CoS values map to different queues, sharing differentiates
services by guaranteeing queue bandwidth. Bandwidth sharing forces minimum bandwidth
per transmit queue. A practical example of using sharing is with high-bandwidth applications
such a Network File System (NFS). Generally, applications using NFS require high
bandwidth with minimal packet loss. Configuring sharing at 500 Mbps for transmit queue 2 and
mapping NFS packets to transmit queue 2 forces the switch to provide 500 Mbps of egress
traffic to the adjacent switch for NFS packets. In this configuration, the system administrator
Example 7-22 Sample Configuration of Interface Configured for Strict-Priority Queuing
Current configuration : 327064 bytes
!
(text deleted)
qos
!
(text deleted)
!
interface FastEthernet3/1
switchport access vlan 2
switchport voice vlan 700
no snmp trap link-status
tx-queue 3
priority high
spanning-tree portfast
!
(text deleted)
!
end
228 Chapter 7: QoS Features Available on the Catalyst 4000 IOS Family of Switches and the Catalyst
must adjust other transmit queues’ bandwidth rates to compensate for the 500 Mbps of traffic
for transmit queue 2 given that the total bandwidth of the egress interface is limited to 1 Gbps.
Example 7-23 provides a sample configuration for the described application of sharing.
The switch maintains sharing rates by treating all queues as high-priority queues during
periods when a transmit queue’s egress traffic rate is below the configured share values.
Initially, the switch round-robins packets until a queue reaches its share. At this instance,
the switch services round-robin all other queues under the defined share. The switch still
handles a configured strict-priority queue as defined in the “Strict-Priority Queuing”
section. The switch services the strict-priority queue before all other queues until it reaches
its configured share value. When all queues reach their share rate, the switch services the
queues round-robin. The default bandwidth parameter applied to each transmit queue is 250
Mbps. Misconfiguring bandwidth parameters may result in transmit queue starvation,
where the switch does not service a queue with a low-bandwidth parameter sufficiently.
To configure guaranteed minimum bandwidth per output queue, use the following interface
transmit queue command:
bandwidth
bandwidth
bandwidth specifies the guaranteed minimum bandwidth in bps using the optional prefixes
kilo, mega, and giga, using the k, m, and g command options, respectively.
Example 7-24 illustrates configuration of 17.1 Mbps as the minimum bandwidth on
transmit queue 3.
Example 7-23 Sample Configuration of Shaping
Building configuration...
Current configuration : 225 bytes
!
qos
!
(text deleted)
!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
no snmp trap link-status
tx-queue 1
bandwidth 125 mbps
tx-queue 2
bandwidth 500 mbps
tx-queue 3
bandwidth 125 mbps
!
(text deleted)
!
end
QoS Support on the Catalyst 4000 IOS Family of Switches 229
To demonstrate and measure the behavior of sharing on transmit queues, two packet-
generator ports were connected to the switch as shown in Figure 7-4. The packet-generator
port connected to Gigabit Ethernet 1/1 was sending traffic with a DSCP value of zero at 1.0
Gbps. The packet-generator port connected to Gigabit Ethernet 1/2 was sending traffic with
a DSCP value of 40 at 1.0 Gbps. The traffic sent by both interfaces was intended for another
traffic port connected to interface Gigabit Ethernet 5/1. Connected to interface Gigabit
Ethernet 5/1 was a traffic-generator port measuring the traffic rate for each DSCP flow.
Three trials were conducted. The first trial involved the default configuration of bandwidth,
whereas the remaining trials applied the bandwidth parameter at 200 Mbps, 750 Mbps, and
900 Mbps, respectively. Table 7-5 summarizes the results of the trial. Example 7-25
displays the basic configuration used for the trial.
Figure 7-4 Network Diagram that Demonstrates Sharing
Example 7-24 Configuring Interface with Bandwidth Parameter
Switch#config terminal
Switch(config)#interface GigabitEthernet 1/1
Switch(config-if)#tx-queue 4
Switch(config-if-tx-queue)#bandwidth 17.1m
Switch(config-if-tx-queue)#end
Table 7-5 Sharing on Transmit Queues
Received Rate
Default
Configuration
Configured
Bandwidth
(200 Mbps)
Configured
Bandwidth
(750 Mbps)
Configured
Bandwidth
(900/100)
Rate received on
Gigabit Ethernet 3/1
for traffic with
DSCP value of 40
500 Mbps 480 Mbps 750 Mbps 900pps
Rate received on
Gigabit Ethernet 3/1
for traffic with
DSCP value of 0
500 Mbps 520 Mbps 250 Mbps 100Mbps
Catalyst 4506 with
Supervisor III Engine
Packet
Generator
Gig1/1
Gig1/2
Gig 5/1
..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset