74 Chapter 3: Overview of QOS Support on Catalyst Platforms
Figure 3-1 General Catalyst QoS Packet-Flow Architecture
QoS Support on the Catalyst 2900XL and 3500XL
Specific models of the Catalyst 2900XL and 3500XL support QoS classification and
congestion management. Ingress packet CoS values and configured port priorities exclu-
sively determine classification of ingress frames for placement into either a low-priority or
high-priority global transmit queue. The two global transmit queues with priority sched-
uling create the congestion management mechanism. The following sections discuss these
QoS features with detailed overviews, configuration guidelines, and examples.
General Catalyst Switch CoS Architecture
Ingress Packet
Classification
Input Scheduling
Layer 2/3 Lookup
Policing
Rewrite
Output
Scheduling
Egress Packet
QoS Support on the Catalyst 2900XL and 3500XL 75
Catalyst 2900XL Product Family Delineation
QoS support on the Catalyst 2900XL and 3500XL platforms is software and model
dependent. For the 2900XL, the original-edition models do not support QoS features,
including the uplink modules for the Catalyst 2916M. All standard- and enterprise-edition
models do support QoS features. Table 3-6 indicates which 2900XL models support QoS
features. All models of the 3500XL support QoS features. In addition, the Catalyst
3524XL-PWR-XL and the 3548XL support CoS reclassification. This QoS feature is not
available on other 3500XL platforms.
Catalyst 2900XL and 3500XL QoS Architectural Overview
The Catalyst 2900XL and 3500XL switches are limited to QoS features that suit access
layer switches. These features include classification, marking, and congestion management
via the use of output scheduling. Because of these features, the 2900XL and 3500XL fit
well into an end-to-end QoS design with core switches. Figure 3-2 shows a sample network
deploying access layer QoS features with comprehensive QoS features in the core.
Table 3-6 QoS Support by Model of 2900XL
Catalyst 2900XL/
3500XL Model Description
QoS
Support
WS-C2908-XL 8-port 10/100BASE-TX switch No
WS-C2912-XL-A/EN 12-port 10/100BASE-TX switch Yes
WS-C2912MF-XL 12-port 100BASE-FX switch Yes
WS-C2916M-XL 16-port 10/100BASE-TX switch + 2 uplink slots No
WS-C2924-XL 24-port 10/100BASE-TX switch No
WS-C2924C-XL 22-port 10/100BASE-TX + 2-port 100BASE-FX switch No
WS-C2924-XL-A/EN 24-port 10/100BASE-TX switch Yes
WS-C2924C-XL-A/EN 22-port 10/100BASE-TX switch + 2-port 100BASE-FX
switch
Yes
WS-C2924M-XL-A/EN 24-port 10/100BASE-TX switch + 2 uplink slots Yes
WS-C2924M-XL-EN-DC 24-port 10/100BASE-TX switch + 2 uplink slots (DC
power)
Yes
76 Chapter 3: Overview of QOS Support on Catalyst Platforms
Figure 3-2 Network Topology Using Catalyst 3524XLs
Figure 3-3 shows the basic QoS architecture model for the Catalyst 2900XL and 3500XL
discussed in the following sections.
Software Requirements
For QoS feature support, the 2900XL and 3500XL require Cisco IOS Software Release
12.0(5)XP or higher. The 3524-PWR-XL and the 3548XL require 12.0(5)XU or higher for
the reclassification of class of CoS values in frames.
Input Scheduling
The Catalyst 2900XL and 3500XL do not perform input scheduling as ingress packets are
immediately copied to a global, shared memory buffer. As long as the packet-forwarding
rate of the switch is not exceeded, input congestion is not critical to implementing QoS. The
packet-forwarding rates of the Catalyst 2900XL and the Catalyst 3500XL are 1.6 Gbps and
5.0 Gbps, respectively.
Catalyst 6500
with MSFC II
Catalyst 6500
with MSFC II
Cisco IP
Phones
Workstations
Cisco IP
Phones
Workstations
Catalyst 3524-
PWR-XL
Catalyst 3524-
PWR-XL
QoS Support on the Catalyst 2900XL and 3500XL 77
Figure 3-3 Basic QoS Architecture for the Catalyst 2900XLs and 3500XLs Switches
Classification/Reclassification
The Catalyst 2900XL and 3500XL switches both support classification of untagged frames.
Two models of the Catalyst 3500XL switch, the Catalyst 3524-PWR-XL and the Catalyst
3548XL switches, support marking of ingress tagged frames. Classification and marking is
configurable only on a per-port basis, and each port may be configured with a unique CoS
value to be classified.
To configure a Catalyst 2900XL and 3500XL for classification or marking of frames, use
the following interface command:
switchport priority {default
default-priority-id
|
extend {cos
value
| none |
trust} |
override}
The default-priority-id parameter is the CoS value to be assigned to untagged ingress
frames.
The extend option is to configure the 802.1p trust configuration of the connected
appliance on the P1 port of the IP Phone. For example, a Cisco IP Phone can be
configured to trust or reclassify frames received on its P1 port.
Classification
CoS = 4-7
Place Packet in
Global Low
Priority Queue
Place Packet in
Global High
Priority Queue
Schedule
L2 Lookup
Transmit Packet
Ye sNo
78 Chapter 3: Overview of QOS Support on Catalyst Platforms
The override option is used to mark tagged frames with the default-priority-id. Only
the Catalyst 3524-PWR-XL and the Catalyst 3548XL switches support this marking
feature.
Example 3-1 shows a Catalyst 3548XL switch port configured to classify untagged frames
with a CoS value of 2.
Example 3-2 shows a Catalyst 3524-PWR-XL switch port configured for a voice VLAN. In
Cisco IOS Software Release 12.0.x, voice VLAN ports must be configured as trunk ports.
NOTE The Catalyst 2900XL and 3500XL software configuration for voice VLANs differs from
the Catalyst switches that run Cisco IOS Software Release 12.1, such as the Catalyst 4000
Supervisor III and IV. Cisco IOS Software Release 12.1 does not require voice VLAN ports
to be configured as trunks.
Example 3-1 Catalyst 3548XL Switch Port Configured to Classify Untagged Frames
Switch#show running-config
Building configuration...
Current configuration:
(text deleted)
!
interface FastEthernet0/48
switchport priority default 2
spanning-tree portfast
(text deleted)
end
Example 3-2 Catalyst 3548XL Switch Port for Voice VLANs
Switch#show running-config
Building configuration...
Current configuration:
(text deleted)
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
switchport voice vlan 70
spanning-tree portfast
(text deleted)
end
..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset