Flat

A flat network in Neutron describes a network in which no VLAN tagging takes place. Unlike VLAN networks, flat networks require that the physical interface of the host associated with the network be connected directly to the bridge. This means that only a single flat network can exist per physical interface.

Figure 4.3 demonstrates a physical interface connected directly to a Neutron-managed bridge in a flat network scenario:

Figure 4.3

In Figure 4.3, eth1 is connected to the bridge named brqZZZZ along with three tap interfaces that correspond to guest instances. No VLAN tagging for instance traffic takes place in this scenario.

On the compute node, the preceding diagram can be realized as the following brctl show output:

On the physical switch, the necessary configuration to facilitate the networking described here will resemble the following:

vlan 200
name VLAN_200

interface Ethernet1/3
description Provider_Interface_eth1
switchport
switchport mode trunk
switchport trunk native vlan 200
switchport trunk allowed vlan add 200
no shutdown

Alternatively, the interface can also be configured as an access port:

interface Ethernet1/3
description Provider_Interface_eth1
switchport
switchport mode access
switchport access vlan 200
no shutdown

Only one flat network is supported per provider interface. When configured as a trunk port with a native VLAN, the provider interface can support a single flat network and multiple VLAN networks. When configured as an access port, the interface can only support a single flat network and any attempt to tag traffic will fail.

When multiple flat networks are created, a separate physical interface must be associated with each flat network. Figure 4.4 demonstrates the use of a second physical interface required for the second flat network:

Figure 4.4

On the compute node, the use of two physical interfaces for separate flat networks can be realized as the following brctl show output:

On the physical switch, the necessary configuration to facilitate the networking described here will resemble the following:

vlan 200
name VLAN_200
vlan 201
name VLAN_201
 interface Ethernet1/3
description Flat_Provider_Interface_eth1
switchport
switchport mode trunk
switchport trunk native vlan 200
switchport trunk allowed vlan add 200
no shutdown
interface Ethernet1/4
description Flat_Provider_Interface_eth2
switchport
switchport mode trunk
switchport trunk native vlan 201
switchport trunk allowed vlan add 201
no shutdown

With the two flat networks, the host does not perform any VLAN tagging on traffic traversing those bridges. Instances connected to the two bridges require a router to communicate with one another. Given the requirement for unique interfaces per flat network, flat networks do not scale well and are not common in production environments.

..................Content has been hidden....................

You can't read the all page of ebook, please click here login for view all page.
Reset